PHPアップデート後のセッションエラー対策

提供: ウィキデュッカ
移動: 案内検索

yum で PHP のアップデートを行ったところ、MediaWiki にログインできなくなってしまった。

・・ときの対策。

(おそらく MediaWiki 以外でも PhpMyAdmin 等の PHP + セッション を使うものは使えなくなった。はず。)

対策

chmod 777 /var/lib/php/session

以上。

原因

yum update により、セッションを保存するディレクトリのパーミッションが変えられてしまったため、 httpd が書き込めなくなってしまった。


セッションを保存するディレクトリを /tmp とかにしても良いかも。